纯净、安全、绿色的下载网站

首页|软件分类|下载排行|最新软件|IT学院

当前位置:首页IT学院IT技术

react安装antd 解决React在安装antd之后出现的Can't resolve './locale'问题(推荐)

trenki   2021-04-22 我要评论

React在安装antd之后出现的Can't resolve './locale'问题,是因为moment在2.2之后的版本都有问题,而react默认使用了最新的moment,但是在moment@2.18.1中是没有问题的。

解决方案就是配置webpack的alias,将所有的 moment 路径引用导入到 moment@2.18.1

操作步骤

安装moment 依赖 npm install moment@2.18.1

在react项目中使用yarn eject暴露config文件。如果没有安装yarn,则 先使用npm install -g yarn,再使用yarn eject暴露config文件。文件结构如图:

文件结构

config/webpack.config.js中找到alias添加一行"moment$": "moment/moment.js",

步骤3的结果


相关文章

猜您喜欢

网友评论

Copyright 2020 www.1downLoad.net 【第一下载站】 版权所有 软件发布

声明:所有软件和文章来自软件开发商或者作者 如有异议 请与本站联系 点此查看联系方式